Adyen virtual terminal payments
Incident Report for BCH Digital Ltd
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 15:54 BST
Investigating
We're currently investigating an issue with agents not being able to process payments on the virtual terminal after they hit submit to take payment.

We will provide further details as soon as possible.

Thanks
Posted Oct 07, 2020 - 15:48 BST