Cardstream Gateway
Incident Report for BCH Digital Ltd
Resolved
Cardstream have confirmed that the issue is resolved.
Posted Jun 05, 2023 - 16:33 BST
Monitoring
Cardstream can confirm that services have returned to normal, their engineers are continuing to monitor.
Posted Jun 05, 2023 - 13:43 BST
Investigating
Cardstream is urgently investigating an incident that is intermittently affecting access to the Merchant Management Systems (MMS) and Transaction processing.

They are treating this with the highest priority and working with engineers to resolve it.
Posted Jun 05, 2023 - 13:18 BST
This incident affected: 💷 Payment Services (💳 Payment Gateways).