Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 18, 2024 - 20:00 GMT
Scheduled
Please be advised that there will be a brief, unavoidable network service interruption of up to 15 minutes occurring at some point between 20:00 on November 18th and 04:00 on November 19th. This temporary disruption is necessary to complete essential network maintenance.
No action is required on your part.
Posted Oct 29, 2024 - 15:48 GMT
This scheduled maintenance affected: 🖥 Platforms (💳 Payments).