Cashflows Down

Incident Report for BCH Digital Ltd

Resolved

Cashflows have confirmed that no further issues have been observed.
Posted May 30, 2025 - 09:17 BST

Monitoring

Cashflows have advised that a fix has been implemented and that they are monitoring the results.
Posted May 29, 2025 - 10:47 BST

Investigating

Cashflows have reported that they are urgently investigating an incident that is affecting transaction processing this morning.
Our monitoring has identified that transactions have been receiving a 65550 response since 09:47 BST 29/05.

We will provide any further updates once received from Cashflows.
Posted May 29, 2025 - 10:25 BST
This incident affected: 🖥 Platforms (💳 Payments).