Cardstream Gateway
Incident Report for BCH Digital Ltd
Resolved
This incident has been resolved.
Posted May 24, 2023 - 09:23 BST
Monitoring
Cardstream can confirm a fix has now been implemented and they are monitoring results.
Posted May 23, 2023 - 15:34 BST
Investigating
Cardstream are urgently investigating an incident that is intermittently affecting access to the Merchant Management Systems (MMS) and Transaction processing.

They are treating this with the highest priority and working with engineers to resolve it.
Posted May 23, 2023 - 12:49 BST
This incident affected: 💷 Payment Services (💳 Payment Gateways).