PCI Regular Scheduled Updates

Scheduled for Jul 16, 21:00 BST  -  Jul 17, 01:00 BST

Update

This update has been rescheduled to a day later and will be performed on Thursday 16th July instead.
Posted Jul 13, 2026 - 11:00 BST

Scheduled

We will be running routine updates and maintenance on the platform to ensure we have the latest security patches and all systems are functioning as required. During this time there will be brief interruptions to service and every effort will be made to keep these periods to a minimum.
Posted Jun 25, 2026 - 16:03 BST
This scheduled maintenance affects: 🖥 Platforms (💳 Payments).