Connection delay on out dial / pickup
Incident Report for BCH Digital Ltd
Resolved
This incident has been resolved.
Posted Jul 12, 2023 - 09:20 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2023 - 12:22 BST
Investigating
There's currently a delay when dialing outbound from the softphone.

Any calls inbound to the softphone are also delayed before it starts to ring.

We are investigating and will update as soon as possible.
Posted Jul 11, 2023 - 10:45 BST
This incident affected: 🌐 Hosted PBX (📞 Softphone).