Web portal Service Setups
Incident Report for BCH Digital Ltd
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 15:09 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2021 - 09:59 GMT
Investigating
We're currently investigating an issue on the web portal for users trying to access Service Setups in Card Payment Processing.

Users will currently see an error screen when trying to access the service.
Posted Jan 12, 2021 - 16:42 GMT
This incident affected: 🖥 Platforms (💻 Web Portal).